首页天道酬勤ubuntu离线安装opencv,ubuntu20.04安装opencv

ubuntu离线安装opencv,ubuntu20.04安装opencv

张世龙 05-04 04:19 36次浏览

安装opencv链接:https://www.Jian Shu.com/p/59608 e 83 becb。

使用3.4.10可以减少vins-fusion的opencv环境问题。 使用扩展模块xfeatures2d时,由于sift、surf等有专利,因此必须在cmake-gui中设置OPENCV_ENABLE_NONFREE。 具体步骤见3330

2 .修复某些版本问题的错误(这些错误可以跳转到IDE中定义的位置进行解决)1.error: ‘CV_GRAY2RGB’ was not declared in this scope

# include opencv2/img proc/types _ c.h

2.error:‘CV_ADAPTIVE_THRESH_MEAN_C’ was not declared in this scope

# include opencv2/calib 3d/calib 3d _ c.h

3.error: ‘CV_AA’ was not declared in this scope

# include“opencv2/img proc/img proc _ c.h”

4.error: ‘CV_LOAD_IMAGE_GRAYSCALE’ was not declared in this scope

# include ' opencv2/img codecs/legacy/constants _ c.h '

要在ubuntu20.04上编译和使用vinsmono,请注意ceres将安装1.14版,并注意https://github.com/hkust-aerial-robotics/vins

3.GDB调试gdb启动ROS程序“ROS run-- prefix‘GD B- ex run-- args’package node”package表示包,node表示需要启动的节点。 程序执行后,发生段错误时,对应的vins_node执行指令如下所示。 (xx必须替换为自己的目录。)。

ROS run---prefix‘GD B- ex run---args’vins vins _ node/home/xx/catkin _ ws/src/vins-fusion/config/eeed

4 .使用opencv4.0或更高版本执行4.VIS_Fusion时发生段错误。 gdb调试后,发现问题的是读取yaml配置文件,然后将opencv重新加载到3.4.10,错误消失并成功执行。 原因不明。

5.ubuntu使用vscode cmake基础流程参考:

链接:https://code.visual studio.com/docs/CPP/cmake-Linux。

必须设置命令行参数的引用。

链接:https://github.com/Microsoft/vs code-cmake-tools/blob/develop/docs/debug-launch.MD # debug-using-using

注意如果在vscode的gdb调试错误中找不到可执行文件路径,则必须将cmake模式更改为debug,然后重新生成可执行文件,不能直接使用release。

ubuntu查看opencv,Ubuntu18安装opencv