首页天道酬勤Linux 安装mysql,node切换版本

Linux 安装mysql,node切换版本

张世龙 05-04 04:36 99次浏览

由于node、npm版本不兼容,编译ambari源代码失败。 必须重新安装nodejs

本博客详细介绍了这个过程

文章目录

一. 完全卸载nodejs

1.1 yum卸载nodejs安装包1.2卸载残留二. 安装指定版本的nodejs

一. nodejs 1.1 yum卸载nodejs安装软件包使用yum remove命令删除nodejs软件包手动删除yum remove nodejs npm -y 1.2卸载残留物#删除node.node usr/locar RM-RF/usr/local/include/node * RM-RF/usr/local/node * #文件夹中的node和node_modules文件夹find~///删除usr/local/wx dhb/NP MRM-RF/usr/local/share/man/man1/node.1rm-RF/usr/wx dhb /

下载nodejs

屏幕显示如下,选择相应的版本并下载

# nodejs wget https://nodejs.org/dist/v 6.17.1/node-v 6.17.1-Linux-x64.tar.gztar-zxvf node-v 6.17.1

如图所示,已成功配置指定版本的nodejs安装

linux卸载nodejs,ubuntu安装mongodb