首页天道酬勤ubuntu安装telnet,esp8266串口调试

ubuntu安装telnet,esp8266串口调试

张世龙 05-12 05:09 130次浏览

下载espnet :3359 github.com/espnet/espnet

在这里,我们将共享一个下载GITHUB项目的代理点,并使用http://gitd.cc/

官方安装文档: https://espnet.github.io/espnet/installation.html

ESPNet的构建过程在网上有很多。 他们在构建的时候,还会安装Python或者安卓。 但是,对于电脑已经有环境的人来说,个人觉得这不是最佳的方法。 以下是个人方法。

解压缩后进入tools文件夹。

请先查一下cuda的路径:

whereis cuda

接下来,指向路径。

sudo sh ./setup_cuda_env.sh (您的路径) ) ) ) ) ) ) ) )。

根据官方文档设置Python环境。

我已经有Python了,但是没有安卓。 我选择b,从系统Python设置venv,也就是说,从正在使用系统的Python创建新的虚拟环境。 cd espnet-root/tools

./setup _ venv.sh $ (command-vpython3)

要开始安装ESPnet,在安装过程中需要下载很多库文件。 众所周知,直接安装会使下载速度慢,容易超时报告错误。

修改脚本文件,把PIP源换成清华吧(其他的也可以)。

打开makefile文件,第125、126行:

是py torch.done : activate _ python.sh ./activate _ python.sh python3- mpipinstallnumpy-- upgrade-I 3359 pi . workaround for ' importerror : numpy.core.multiarrayfailedtoimport './activate _ python.sh python3- mpipinstall $ [

espnet.done 3360 py torch.don econda _ packages.done./activate _ python.sh python3- mpipinstall-e.-I https://pi shon

ifneq($(strip$ ) no_cupy ) )、(./activate _ python.sh python3- mpipinstall $ (pip _ chainer )-I https://pi . simplesoole precompiledcupy==6.0.0for python=3.8 is not provided ./activate _ python.sh\if python3- c ' importsyon from distutils.versionimportlooseversionasl; assertL(sys.version ) L('3.8 ' ) (21 /dev/null; then (python3- mpipinstall-I https://pypi.tuna.Tsinghua.edu.cn/简单some-package $ (pip _ chainer ) cupy-cuddage ) ) pip_chainer (else ) python3- mpipinstall-I https://pi.tud 我正在安装1.2的pytorch

make TH_VERSION=1.2

可能漏掉了一点,如果有,自己发掘,加上-i酱就可以了。

如果不能再这样了,直接自己在网上下载库的whl文件,放入虚拟环境的库文件中。

在最后一步测试安装:

make check_install

nlp神经语言学6步骤,语音识别开发板